HFD Outage

Incident Report for HFD

Resolved

Issue has been resolved. All services are operational
Posted Mar 25, 2025 - 16:04 PDT

Investigating

There is an outage at HFD. We are currently investigating the issue
Posted Mar 25, 2025 - 15:54 PDT
This incident affected: API Gateway, Provider Portal, Customer Portal, Full API, and Easy Apply.